Minnesota 1 - Scheduled Power Curtailment

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Jun 07, 2025 - 13:35 UTC

Identified

The Minnesota facility is set for curtailment on June 6th, from 7:00 AM to 9:00 PM Central Time. However, this schedule may shift or begin earlier. Once power is restored, the onsite team will swiftly bring the miners back online. Thank you for your patience and understanding.
Posted Jun 06, 2025 - 04:58 UTC
This incident affected: Minnesota, United States.