Indiana 3 - Power Outage

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Aug 27, 2026 - 01:08 UTC

Investigating

We are currently experiencing a partial outage at the Indiana 3 site.

Our team is currently investigating the issue. We will provide updates as more information becomes available.

Thank you for your patience and understanding.
Posted Aug 26, 2026 - 23:13 UTC
This incident affected: Indiana 3.