Manitoba 8 Network Maintenance

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Nov 29, 2023 - 01:53 UTC

Investigating

Manitoba 8 is swapping their ISP service. Units will be down until the swap is complete.
Posted Nov 28, 2023 - 17:28 UTC
This incident affected: Manitoba 8, Canada.