(42x) North Carolina 1 Partial Outage
Incident Report for Compass Mining
Resolved
This incident has been resolved.
Posted Mar 23, 2023 - 14:04 UTC
Identified
A subset of less than 50 units are affected by an electrical component failure. We expect this issue to be resolved by next week.
Posted Mar 17, 2023 - 22:28 UTC