Iowa 2 & 3 - Partial Outage

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Aug 22, 2025 - 18:14 UTC

Update

We are continuing to investigate this issue.
Posted Aug 21, 2025 - 17:51 UTC

Update

We are continuing to investigate this issue.
Posted Aug 21, 2025 - 17:50 UTC

Update

We are continuing to investigate this issue.
Posted Aug 21, 2025 - 17:50 UTC

Investigating

We are experiencing a partial outage at Iowa 2 & 3.

You may experience disruption of service for your miner(s) at this site as a result. Our team is investigating this and will provide updates as they become available.
Posted Aug 21, 2025 - 17:49 UTC
This incident affected: Iowa 2, United States and Iowa 3, United States.