Minnesota 1 - Scheduled Power Curtailment

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Jun 10, 2025 - 07:02 UTC

Identified

The Minnesota facility is scheduled for curtailment on June 9th, from 5:00 AM to 12:00 PM Central time, and another in the evening from 8:00 PM to 9:00 PM Central time.

The onsite team will restore the miners as soon as power returns. Thank you for your patience and understanding.
Posted Jun 09, 2025 - 04:14 UTC
This incident affected: Minnesota, United States.