Manitoba 2 Outage
Incident Report for Compass Mining
Resolved
This incident has been resolved.
Posted Dec 05, 2024 - 11:00 UTC
Identified
MB2 is currently down due to an outage in the area. We are monitoring the situation closely and will share updates as soon as it is resolved.
Posted Dec 05, 2024 - 09:06 UTC
This incident affected: Manitoba 2, Canada.