MB6 - Power Outage
Incident Report for Compass Mining
Resolved
This incident has been resolved.
Posted Jul 15, 2024 - 23:40 UTC
Update
We are continuing to investigate this issue.
Posted Jul 15, 2024 - 23:39 UTC
Investigating
MB6 is currently offline. Techs are currently onsite troubleshooting the issue.
Posted Jul 15, 2024 - 21:52 UTC
This incident affected: Manitoba 6, Canada.