Minnesota 1 - Scheduled Power Curtailment

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Jun 13, 2025 - 12:28 UTC

Update

Another scheduled curtailment is set for June 12th, from 5:00 PM to 6:00 PM Central Time, and again from 7:00 PM to 9:00 PM Central Time. We'll provide an update as soon as we receive new information.
Posted Jun 12, 2025 - 03:31 UTC

Identified

The Minnesota facility will undergo a scheduled curtailment today, June 11th, from 3:00 PM to 10:00 PM Central Time.

Once power is restored, the onsite team will promptly bring the miners back online. We appreciate your patience and understanding.
Posted Jun 11, 2025 - 07:18 UTC
This incident affected: Minnesota, United States.