Nebraska 2 - Partial Outage

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Jun 03, 2025 - 06:26 UTC

Identified

We’re currently experiencing an outage affecting 36 units in one of our racks. Our team is actively working to resolve the issue and restore service as quickly as possible.

We appreciate your patience and cooperation.
Posted Jun 02, 2025 - 08:21 UTC
This incident affected: Nebraska 2, United States.