Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 20, 2025 - 22:00 UTC
Scheduled
Our Ontario 1 facility will be curtailing today, January 20, 2025 from 5PM to 8PM EST. The onsite team will bring the miners back online as soon as power is fully restored. We appreciate your patience and cooperation.
Posted Jan 20, 2025 - 15:37 UTC
This scheduled maintenance affected: Ontario, Canada.