Newfoundland 1 Network Outage
Incident Report for Compass Mining
Resolved
This incident has been resolved.
Posted Sep 16, 2022 - 20:18 UTC
Investigating
Our facility in NL1 is experiencing an internet outage today. We will provide updates as they become available.
Posted Sep 16, 2022 - 13:49 UTC