Texas 5 - Maintenance
Incident Report for Compass Mining
Resolved
The scheduled maintenance has been completed.
Posted Jul 16, 2024 - 17:03 UTC
Identified
Texas 5 is performing maintenance today 07/16 at 7:30AM CST. The onsite team will bring the miners back online as soon as the maintenance period has ended.
We appreciate your cooperation.
Posted Jul 16, 2024 - 12:39 UTC
This incident affected: Texas 5, United States.