Texas 3 - Outage
Incident Report for Compass Mining
Resolved
This incident has been resolved.
Posted Apr 22, 2024 - 09:33 UTC
Update
The facility is presently encountering a power outage. We'll provide further updates as soon as we receive more details from the site.
We appreciate your patience and cooperation.
Posted Apr 22, 2024 - 09:23 UTC
Identified
The site will experience a 24-hour outage for electrical meter calibration purposes.
The onsite team will promptly restore the miners once power is fully reinstated.
We appreciate your cooperation.
Posted Apr 19, 2024 - 09:29 UTC
This incident affected: Texas 3, United States.