Texas 5 - Transformer maintenance

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted May 18, 2026 - 05:23 UTC

Update

We are continuing to work on a fix for this issue.
Posted May 14, 2026 - 06:10 UTC

Update

We are continuing to work on a fix for this issue.
Posted May 14, 2026 - 06:08 UTC

Identified

We are partially powering down the facility for a transformer maintenance. Our technicians will bring miners back online as soon as the maintenance is complete. 

Thank you for your patience and understanding.
Posted May 14, 2026 - 06:04 UTC
This incident affected: Texas 5, United States.