Texas 1 - Partial outage
Incident Report for Compass Mining
Resolved
This incident has been resolved.
Posted Oct 30, 2024 - 10:08 UTC
Investigating
We are currently investigating the issue.
Posted Oct 30, 2024 - 05:23 UTC
This incident affected: Texas 1, United States.