North Dakota - Maintenance

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Apr 07, 2026 - 18:07 UTC

Identified

The Facility will undergo routine maintenance on April 7 12:00 AM to 7:00 AM CST. During this process, small-scale intermittent downtime may occur.

Our technicians will bring miners back online as soon as the maintenance period is complete. Thank you for your patience and understanding.
Posted Apr 06, 2026 - 16:52 UTC
This incident affected: North Dakota, United States.