(55x) Minnesota Electrical Issue
Incident Report for Compass Mining
Resolved
This incident has been resolved.
Posted Mar 27, 2023 - 14:01 UTC
Update
Electrician's are onsite to replace the failed breaker. Side wide downtime is expected while this is being done. We anticipate this work take only a few hours.
Posted Mar 24, 2023 - 12:33 UTC
Identified
After electrical maintenance an issue was found with one container's main breaker. Electricians will be onsite this week to determine best course of action. We will provide updates as soon as we have them.
Posted Mar 08, 2023 - 21:18 UTC
This incident affected: Minnesota, United States.