Texas 5 and Texas 5 (2) - Power curtailment

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Sep 03, 2026 - 05:03 UTC

Identified

Our Texas 5 and Texas 5(2) facilities are currently undergoing power curtailment. Miners will be brought back online by our technicians as soon as the curtailment period ends.
Posted Sep 03, 2026 - 02:12 UTC
This incident affected: Texas 5, United States and Texas 5 (2).