Ohio 2 Electrical Maintenance
Incident Report for Compass Mining
Resolved
This incident has been resolved.
Posted May 31, 2023 - 17:20 UTC
Monitoring
There will be a short outage today lasting roughly 20 minutes.
Posted May 31, 2023 - 14:00 UTC
This incident affected: Ohio 2, United States.