Texas 1- Partial Outage
Incident Report for Compass Mining
Resolved
This incident has been resolved.
Posted Jul 30, 2024 - 01:42 UTC
Update
There is an issue on the utility side of the substation. Our on-site team is currently working to get it resolved as soon as possible.
Posted Jul 29, 2024 - 14:29 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 27, 2024 - 00:25 UTC
This incident affected: Texas 1, United States.