Minnesota 1 - Scheduled Power Curtailment

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Jun 11, 2025 - 07:16 UTC

Identified

The Minnesota facility will undergo a scheduled curtailment today, June 10th, from 3:00 PM to 11:00 PM Central Time.

Once power is restored, the onsite team will promptly bring the miners back online. We appreciate your patience and understanding.
Posted Jun 10, 2025 - 13:04 UTC
This incident affected: Minnesota, United States.