Ohio 2 - Maintenance

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Aug 07, 2025 - 19:09 UTC

Identified

Our Ohio 2 facility is experiencing ongoing maintenance on a portion of the site (C3) for network maintenance. The onsite team will bring the miners back online as soon as this is resolved. We appreciate your patience and cooperation.
Posted Aug 07, 2025 - 17:25 UTC
This incident affected: Ohio 2, United States.