Ontario 1- Power Curtailment
Incident Report for Compass Mining
Resolved
This incident has been resolved.
Posted Jul 17, 2024 - 07:24 UTC
Identified
Ontario 1 will be curtailing from 1pm-10pm EST, units will be offline during this period.
Posted Jul 16, 2024 - 18:11 UTC
This incident affected: Ontario, Canada.