TX8 - Power Curtailment

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted May 06, 2026 - 09:18 UTC

Identified

Our TX8 facility is currently undergoing power curtailment. Miners will be brought back online by our technicians as soon as the curtailment period ends. Thank you for your patience and understanding.
Posted May 06, 2026 - 02:09 UTC
This incident affected: Texas 8.