Nebraska 2 - Partial Outage

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Jun 24, 2025 - 10:28 UTC

Identified

High winds at our Nebraska 2 facility are pushing hot air back into the building by forcing against the exhaust fans. This is affecting airflow and causing elevated temperatures, impacting 714 miners.

The issue is weather-related. Our team is monitoring the situation closely and working to minimize the impact.
Posted Jun 23, 2025 - 07:30 UTC

Investigating

We are currently investigating this issue.
Posted Jun 21, 2025 - 04:48 UTC
This incident affected: Nebraska 2, United States.