Minnesota 1 - Outage

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Oct 04, 2023 - 01:23 UTC

Investigating

We are currently investigating this issue.
Posted Oct 03, 2023 - 22:23 UTC
This incident affected: Minnesota, United States.