Ohio 2 - Power Curtailment
Incident Report for Compass Mining
Resolved
This incident has been resolved.
Posted Jul 18, 2024 - 01:21 UTC
Monitoring
Ohio 2 will be curtailing from 3:00 pm to 8:00 pm EST, units will be offline during this period.
Posted Jul 17, 2024 - 19:12 UTC
This incident affected: Ohio 2, United States.