Ohio 2 - Partial Outage

Incident Report for Compass Mining

Resolved

Updated announcement for Ohio 2.
Posted May 12, 2025 - 12:51 UTC

Identified

Our Ohio 2 facility is experiencing issues with exhaust fans (C12). The onsite team will bring the miners back online as soon as this is resolved. We appreciate your patience and cooperation.
Posted Apr 30, 2025 - 15:40 UTC
This incident affected: Ohio 2, United States.