Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 11, 2024 - 13:30 UTC
Scheduled
Ohio 2 will be shutting down a portion of the site for maintenance today. Our on-site team will bring the miners back online as soon as the maintenance is complete. We appreciate your cooperation.
Posted Oct 10, 2024 - 14:54 UTC
This scheduled maintenance affected: Ohio 2, United States.