Iowa 2 & 3 - Partial Outage

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Jan 06, 2026 - 06:12 UTC

Update

Most sites are now back online. Our onsite team is still working to restore operations at the remaining sites. We hope to have this resolved soon. We thank you for your continued patience and understanding.
Posted Jan 02, 2026 - 11:19 UTC

Investigating

We are experiencing an outage at our Iowa 2/3 facility. Our team is investigating this and will provide updates as they become available.
Posted Dec 29, 2025 - 16:07 UTC
This incident affected: Iowa 2, United States and Iowa 3, United States.