TX8 - Power Curtailment

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Aug 14, 2026 - 02:12 UTC

Identified

Due to an approaching thunderstorm in the area, the Texas 8 facility will be temporarily powered down as a precautionary safety measure.

Our technicians will monitor the weather conditions and begin powering the facility back up as soon as conditions are safe.

We appreciate your patience and understanding. Further updates will be provided as conditions change.
Posted Aug 14, 2026 - 00:40 UTC
This incident affected: Texas 8.