Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 10, 2024 - 20:00 UTC
Scheduled
The Minnesota 1 facility is curtailing 10/10 from 3PM to 8PM CST. Our onsite team will bring the miners back online as soon as power is fully restored. We appreciate your cooperation.
Posted Oct 10, 2024 - 17:31 UTC
This scheduled maintenance affected: Minnesota, United States.