TX8 - Power Curtailment

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Aug 27, 2026 - 06:41 UTC

Identified

Our Texas 8 facility is currently undergoing power curtailment. Miners will be brought back online by our technicians as soon as the curtailment period ends.
Posted Aug 26, 2026 - 23:09 UTC
This incident affected: Texas 8.