Manitoba 8 - Site Maintenance
Incident Report for Compass Mining
Resolved
This incident has been resolved.
Posted Nov 01, 2024 - 07:52 UTC
Investigating
The Manitoba 2 facility will be down while the site performs maintenance. Our team will work to get the miners back online as quickly as possible. Thank you for your patience.
Posted Oct 31, 2024 - 14:41 UTC
This incident affected: Manitoba 8, Canada.