Texas 5B - Routine filter maintenance

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Apr 07, 2026 - 12:17 UTC

Update

We are continuing to work on a fix for this issue.
Posted Mar 24, 2026 - 02:47 UTC

Identified

Facility technicians will be performing routine filtration maintenance over the next week.  Each mining container will be de-energized one at a time to perform the needed work.  Intermittent downtime will occur during this period.
Posted Mar 23, 2026 - 14:54 UTC
This incident affected: Texas 5 (2).