Iowa 3 - Scheduled Electrical Maintenance and Power Curtailment

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Aug 03, 2025 - 05:43 UTC

Identified

Electricians will be conducting maintenance at the site over the next couple of days. Our onsite team will bring the miners back online as soon as maintenance is completed and power is fully restored.
Posted Jul 29, 2025 - 03:54 UTC
This incident affected: Iowa 3, United States.