North Dakota - Maintenance

Incident Report for Compass Mining

Update

We are continuing to work on a fix for this issue. Thank you for your kind understanding.
Posted Aug 28, 2026 - 14:11 UTC

Update

We are continuing to work on a fix for this issue.
Posted Aug 21, 2026 - 16:31 UTC

Identified

There is currently an unexpected outage affecting the North ARC substation. Not all miners are affected, and our on-site team is actively working to resolve the issue.

Thank you for your patience and understanding.
Posted Aug 20, 2026 - 16:06 UTC
This incident affects: North Dakota, United States.