Texas 8 - Power Curtailment

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Jun 30, 2026 - 04:12 UTC

Identified

The local power authority has issued a notice to curtail. Our technicians will bring miners back online as soon as the curtailment period is complete.

Thank you for your patience and understanding.
Posted Jun 29, 2026 - 19:03 UTC
This incident affected: Texas 8.