Minnesota 1 - Power Curtailment

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Jun 03, 2025 - 05:02 UTC

Identified

The Minnesota facility will undergo curtailment today, June 2nd, due to a very hot weather. The first will take place from 6:00 AM to 7:00 AM Central time, and the second will occur in the evening from 12:00 PM to 10:00 PM Central time.

The onsite team will restore the miners as soon as power returns. Thank you for your patience and understanding.
Posted Jun 02, 2025 - 08:09 UTC
This incident affected: Minnesota, United States.