Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 06, 2025 - 17:00 UTC
Scheduled
The Ontario 1 facility is currently curtailing. The onsite team will bring the miners back online as soon as power is fully restored. We appreciate your patience and cooperation.
Posted Feb 06, 2025 - 15:48 UTC
This scheduled maintenance affected: Ontario, Canada.