Texas 5 (2) - Scheduled Maintenance

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Oct 24, 2025 - 16:49 UTC

Identified

The Texas 5 (2) is scheduled for site-wide maintenance today, October 24, 2025, starting at 8:30 AM Central Time. The onsite team will restore operations as soon as maintenance is complete. We appreciate your patience and understanding.
Posted Oct 24, 2025 - 14:24 UTC
This incident affected: Texas 5, United States.