Iowa 3 - Outage
Incident Report for Compass Mining
Resolved
This incident has been resolved.
Posted Dec 07, 2024 - 02:46 UTC
Update
We are continuing to investigate this issue.
Posted Dec 07, 2024 - 01:02 UTC
Investigating
We are currently investigating this issue.
Posted Dec 07, 2024 - 01:02 UTC
This incident affected: Iowa 3, United States.