North Dakota - Partial Outage

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Mar 31, 2026 - 12:43 UTC

Identified

A total of 205 miners in C5 are currently offline due to an electrical issue at the North Dakota facility. On-site personnel are already working to resolve the problem.

Thank you for your understanding.
Posted Mar 30, 2026 - 18:35 UTC
This incident affected: North Dakota, United States.