Texas 1 - Power Curtailment

Incident Report for Compass Mining

Resolved

The incident has been resolved
Posted Nov 22, 2023 - 08:46 UTC

Identified

The Texas 1 facility is currently curtailing. The onsite team will bring on the miners once the power has been fully restored.
We appreciate your cooperation.
Posted Nov 21, 2023 - 15:06 UTC
This incident affected: Texas 1, United States.