Manitoba 7 - Site Maintenance
Incident Report for Compass Mining
Resolved
This incident has been resolved.
Posted Nov 01, 2024 - 16:52 UTC
Identified
The Manitoba 7 facility will be down while the site performs maintenance. Our team will work to get the miners back online as quickly as possible. Thank you for your patience.
Posted Nov 01, 2024 - 15:17 UTC
This incident affected: Manitoba 7, Canada.