Iowa 3 - Partial Outage

Incident Report for Compass Mining

Resolved

This incident has been resolved.

We are currently undergoing site curtailment until 11:00 PM CDT, but after the curtailment period has concluded your miners should begin hashing again.
Posted Jul 29, 2025 - 20:16 UTC

Update

We implemented a fix and are currently monitoring the result.
Posted Jul 29, 2025 - 16:00 UTC

Investigating

Iowa 3 is experiencing a partial outage now.

We are currently investigation this issue.
Posted Jul 29, 2025 - 15:00 UTC
This incident affected: Iowa 3, United States.