North Dakota - Partial Outage

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Nov 25, 2025 - 18:30 UTC

Identified

Facility technicians has identified issues with a coolant pipe branch in a portion of the site. The onsite team will bring the miners back online as soon as this is resolved. We appreciate your patience and cooperation.
Posted Nov 25, 2025 - 15:14 UTC
This incident affected: North Dakota, United States.