North Dakota - Partial Outage

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Apr 23, 2026 - 20:10 UTC

Identified

Due to elevated site temperatures today, April 22, 2026, 20 miners in each container will need to be placed in sleep mode from 1:00 PM to 8:00 PM Eastern Time.

Thank you for your patience and understanding.
Posted Apr 22, 2026 - 11:27 UTC
This incident affected: North Dakota, United States.