Iowa 2 - Relocation

Incident Report for Compass Mining

Update

We wanted to share an update regarding the relocation. There is a slight delay in the initial redeployment timeline.

The miners from Iowa 2 are now offline and are en route to the next hosting facility. Barring any additional unforeseen delays, the miners are expected to be online at the new Compass Mining facility by April 13.
Posted Mar 26, 2026 - 17:43 UTC

Monitoring

We wanted to share an update regarding the relocation.

The miners at Iowa 2 are now offline and are being prepared for shipment. The relocation process is currently underway. Barring any unforeseen delays, the miners are expected to be online at a new Compass Mining facility by March 20.
Posted Mar 03, 2026 - 15:29 UTC
This incident affects: Iowa 2, United States.